Open Source Software / Library

We provide well-known packages and libraries except those in the Linux distributions. We also distribute software sources and environments of Configure and Make to provide the know-how of how to make various packages. If you have any suggestions or comments, please feel free to contact to our programming support desk. Please also tell us if you require software that is not listed below. Their usage conditions are in accordance with individual software conditions. For more information about using the Migrated Software, please refer to the manual of each software.

Key:
+ = Available for all users.
― = Not available for use.

ABINIT

version Module File SystemA SystemB,C
8.10.1 abinit/8.10.1_intel-17.0 +
8.10.1 abinit/8.10.1_intel-17.0-impi-2017.4 +
8.6.3 abinit/8.6.3_intel-17.0 +
8.6.3 abinit/8.6.3_intel-17.0-impi-2017.2 +

/opt/app/abinit

RSS21

Please contact us if you want to use this software.

Please make sure to acknowledge the use of this software in papers when publishing research achievements obtained from the use of this software.

“Electron-correlated fragment-molecular-orbital 
calculations for biomolecular and nano systems”, S. 
Tanaka, Y. Mochizuki, Y. Komeiji, Y. Okiyama, K. 
Fukuzawa, Phys. Chem. Chem. Phys. 16 (2014) 10310-10344.

Anaconda

anaconda version python version Module File SystemA SystemB,C
2/4.2.0 2.7.12 anaconda2/4.2.0 + +
2/5.1.0 2.7.14 anaconda2/5.1.0 + +
2/5.1.0-intel 2.7.14 anaconda2/5.1.0-intel + +
3/4.2.0 3.5.2 anaconda3/4.2.0 + +
3/5.0.1 3.6.3 anaconda3/5.0.1 + +
3/5.0.1-intel 3.6.2 anaconda3/5.0.1-intel + +
3/5.1.0 3.6.4 anaconda3/5.1.0 + +
3/5.1.0-intel 3.6.3 anaconda3/5.1.0-intel + +
3/5.3.1 3.6.7 anaconda3/5.3.1 + +
3/2019.10 3.7.4 anaconda3/2019.10 + +
3/2020.11 3.8.5 anaconda3/2020.11 + +

/opt/app/anaconda2
/opt/app/anaconda3

TensorFlow is available, which is installed as a plugin.

ARPACK - Arnoldi Package

version Module File SystemA SystemB,C
96 arpack/96_cray-8.5 + +
" arpack/96_intel-16.0 + +
" arpack/96_gnu-6.1 +

/opt/app/arpack

BoltzTraP

version Module File SystemA SystemB,C
1.2.5 boltztrap/1.2.5_intel-17.0-impi-2017.4 +

/opt/app/boltztrap

BoltzTraP2

version Module File SystemA SystemB,C
18.5.1 boltztrap2/18.5.1_gnu-7.1-cray-python-17.06.1 +
18.5.1 boltztrap2/18.5.1_intel-17.0-intel-python-3.5.3 +

/opt/app/boltztrap2

This software is a site package of Python. This module loads cray python 17.06.1 on system A, or intel disribution python 3.5.3 on system B/C at the same time.

CMAKE

version Module File SystemA SystemB,C
3.13.2 cmake/3.13.2 +
3.7.1 cmake/3.7.1 +

/opt/app/cmake

In System A, CMAKE 3.5.2 is available, no module needed.

CP2K

version Module File SystemA SystemB,C
8.1 cp2k/8.1.0_gnu-8.1.0-impi-2018.4 - +
8.1 cp2k/8.1.0_intel-18.0.5-impi-2018.4 - +

/opt/app/cp2k

  • python2
Version Module File System A System B,C
2.7.15.6 cray-python/2.7.15.6 +
2.7.15.3 cray-python/2.7.15.3 +
2.7.13.1 cray-python/2.7.13.1 +
  • python3
Version Module File System A System B,C
3.6.5.6 cray-python/3.6.5.6 +
3.6.5.3 cray-python/3.6.5.3 +
3.6.1.1 cray-python/3.6.1.1 +
  • both python 2 and 3 (obsolete)
Version Module File System A System B,C
17.06.1 cray-python/17.06.1 +
17.09.1 cray-python/17.09.1 +

/opt/python

Version Module File System A System B,C
3.4.2 cray-R/3.4.2 +
3.3.3 cray-R/3.3.3 +

/opt/R

FDS

Version Module File SystemA SystemB,C
6.7.1 fds/6.7.1-18.0-impi-2018.4 +
6.5.3 fds/6.5.3-18.0-impi-2018.4 +

/opt/app/fds

FFTE: A Fast Fourier Transform Package

Version Module File System A System B,C
6.0 ffte/6.0_cray-8.5 +
6.0 ffte/6.0_intel-17.0-impi-2017.2 +

/opt/app/ffte

FFTW Home Page

version Module File SystemA SystemB,C
2.1.5.9 fftw/2.1.5.9 +

FFTW Home Page

  • 64bit precision
version Module File SystemA SystemB,C
3.3.8.3 cray-fftw/3.3.8.3 +
3.3.8.2 cray-fftw/3.3.8.2 +
3.3.8.1 cray-fftw/3.3.8.1 +
3.3.6.3 cray-fftw/3.3.6.3 +
3.3.6.2 cray-fftw/3.3.6.2 +
3.3.5 fftw/3.3.5_intel-17.0-impi-2017.1 +
3.3.4.11 fftw/3.3.4.11 +
3.3.4.10 fftw/3.3.4.10 +
3.3.4.9 fftw/3.3.4.9 +
3.3.4.7 fftw/3.3.4.7 +
3.3.4 fftw/3.3.4_intel-17.0-impi-2017.1 +
  • 80bit precision
version Module File SystemA SystemB,C
3.3.4 fftwl/3.3.4_intel-17.0
fftwl/3.3.4_gnu-6.3
+

System A

/opt/cray/pe/fftw

System B,C

/opt/app/fftw

RSS21

Please contact us if you want to use this software.

version Module File SystemA SystemB,C
8.1 frontflow_blue/8.1_intel-18.0 +

/opt/app/frontflow_blue

Those who want to use this software must observe the following conditions. (write acknowledgments in your paper, etc.)

http://www.ciss.iis.u-tokyo.ac.jp/dl/download/permission.php?group_id=7

RSS21

Please contact us if you want to use this software.

Those who want to use this software must observe the following conditions. (write acknowledgments in your paper, etc.)

http://www.ciss.iis.u-tokyo.ac.jp/dl/download/permission.php?group_id=7

FrontISTR

vesion Module File Sydtem A SystemB,C
5.1.1 frontistr/5.1.1_intel-18.0 +
5.0b frontistr/5.0b_intel-18.0 +

/opt/app/frontistr

Gordon Group / GAMESS Homepage

version Module File SystemA SystemB,C
2016_r1 gamess/2016R1_intel-17.0-impi-2017.1 +
2014_r1 gamess/2014R1_cray-8.5
gamess/2014R1_intel-16.0
+
2014_r1 gamess/2014R1_intel-16.0-impi-5.1 +

/opt/app/gamess

GDAL

version Module File SystemA SystemB,C
3.0.3 gdal/3.0.3_gnu-8.1 +
2.4.4 gdal/2.4.4_gnu-8.1 +

/opt/app/gdal

GENESIS

version モジュールファイル名 システムA システムB,C
1.5.1 genesis/1.5.1_intel-18.0 +
1.3.0 genesis/1.3.0_intel-18.0 +

/opt/app/genesis

Git

$ git

version Module File SystemA SystemB,C
2.27 git/2.27_gnu-4.8 +

/opt/app/git

In system A, you can use a recent git by default, don't need to load a module.

The GMT Home Page

version Module File SystemA SystemB,C
5.4.1 gmt5/5.4.1_intel-17.0 +
5.4.1 gmt5/5.4.1_intel-17.0-impi-2017.2 +
4.5.13 gmt4/4.5.13_gnu-5.3 +

/opt/app/gmt

On system A, when you use GMT by batch job, please add -q option to aprun command in the job script.

Example:

#!/bin/bash
#QSUB -q gr19999a
#QSUB -ug gr19999
#QSUB -A p=1:t=1:c=1:m=1355M

aprun -q -n $QSUB_PROCS -d $QSUB_THREADS -N $QSUB_PPN gmt psbasemap -R0/6.5/0/7.5 -Jx1i -B0 -P -K > out.ps

gnuplot homepage

version Module File SystemA SystemB,C
5.0.4 gnuplot/5.0.4 + +

/opt/app/gnuplot

Grace

Version Module File System A System B,C
5.1.25 grace/5.1.25_gnu-4.8 +

/opt/app/grace

GrADS Home Page

version Module File SystemA SystemB,C
2.2.0 grads/2.2.0_intel-18.0-impi-2018.0 +
2.2.0 grads/2.2.0 +
2.0.2 grads/2.0.2_intel-17.0-impi-2017.2 +
2.0.2 grads/2.0.2_gnu-5.3 +

/opt/app/grads

Gromacs

version Module File SystemA SystemB,C
2016.4 gromacs/2016.4_intel-17.0-impi-2017.2 +
2016.4 gromacs/2016.4_intel-17.0 +

/opt/app/gromacs

HDF Group

Version Module File SystemA SystemB,C
4.2.13 hdf4/4.2.13 +

/opt/app/hdf4

HDF Group -HDF5

  • single execution
Version Module File SystemA SystemB,C
1.10.5.1 cray-hdf5/1.10.5.1 +
1.10.2.0 cray-hdf5/1.10.2.0 +
1.10.1.1 cray-hdf5/1.10.1.1 +
1.10.0.3 cray-hdf5/1.10.0.3 +
1.10.0.1 cray-hdf5/1.10.0.1 +
1.10.0 cray-hdf5/1.10.0 +
1.10.0 hdf5/1.10.0_intel-17.0
hdf5/1.10.0_gnu-4.8
+
1.8.17 hdf5/1.8.17_intel-16.0
hdf5/1.8.17_cray-8.5
hdf5/1.8.17_gnu-4.8
+
1.8.16 cray-hdf5/1.8.16 +
  • parallel execution
Version Module File SystemA SystemB,C
1.10.5.1 parallel cray-hdf5-parallel/1.10.5.1 +
1.10.2.0 parallel cray-hdf5-parallel/1.10.2.0 +
1.10.1.1 parallel cray-hdf5-parallel/1.10.1.1 +
1.10.0.3 parallel cray-hdf5-parallel/1.10.0.3 +
1.10.0.1 parallel cray-hdf5-parallel/1.10.0.1 +
1.10.0 parallel cray-hdf5-parallel/1.10.0 +
1.10.0 parallel hdf5-parallel/1.10.0_intel-17.0-impi-2017.1 +
1.8.17 parallel hdf5-parallel/1.8.17_intel-17.0-impi-2017.1
hdf5-parallel/1.8.17_cray-8.5-impi-5.1
+
1.8.16 parallel cray-hdf5-parallel/1.8.16 +

System A

/opt/cray/pe/hdf5
/opt/cray/pe/hdf5-parallel

System B,C

/opt/app/hdf5
/opt/app/hdf5-parallel

HYPRE: Scalable Linear Solvers and Multigrid Methods

Version Module File System A System B,C
2.14 cray-tpsl/19.06.1 +
2.11 cray-tpsl/18.06.1 +
cray-tpsl/17.11.1 +
cray-tpsl/16.12.1 +
2.11.1 hypre/2.11.1_intel-17.0-impi-2017.2 +

System A

/opt/cray/pe/tpsl

System B,C

/opt/app/hypre

Hφ: Quantum Lattice Model Simulator Package

Version Module File System A System B,C
3.4.0 hphi/3.4.0_intel-18.0 +
3.1.2 hphi/3.1.2_intel-17.0 +

/opt/app/hphi

Intel Distribution for Python

version Module File SystemA SystemB,C
3.5.3 intel-python/3.5.3_2017.3 +
2.7.13 intel-python/2.7.13_2017.3 +

/opt/app/intel/intelpython

The Julia Language

Version Module File SystemA SystemB,C
1.2.0 julia/1.2.0 + +
1.0.1 julia/1.0.1 + +

In system A, Julia is available by batch job execution. In the batch job script, execute a shell script by aprun, then execute julia in the shell script. The source code to be run by Julia must be input by redirection.

  • Example of job script
$ cat jobscript.sh

#!/bin/bash
#QSUB -q gr19999a
#QSUB -ug gr19999

aprun -b sh source.sh
$ cat source.sh

#!/bin/bash
julia < hello-world.jl
  • Example of execution
$ qsub jobscript.sh

/opt/app/julia

LAMMPS Molecular Dynamics Simulator

Version Module File SystemA SystemB,C
7Aug19 lammps/7Aug19_intel-18.0 + +
22Aug18 lammps/22Aug18_intel-17.0 + +
11Aug17 lammps/11Aug17_intel-18.0 + +
17Nov16 lammps/17Nov16_intel-17.0 +

/opt/app/lammps

Lis: Library of Iterative Solvers for Linear Systems

Version Module File System A System B,C
2.0.4 lis/2.0.4_intel-18.0 +
2.0.4 lis/2.0.4_intel-18.0-impi-2018.0 +
1.7.27 lis/1.7.27_intel-17.0
lis/1.7.27_cray-8.5
+
1.7.27 lis/1.7.27_intel-17.0-impi-2017.2 +

/opt/app/lis

Meep-AbInitio

version Module File SystemA SystemB,C
1.3 meep/1.3_intel-17.0 +
" meep/1.3_intel-16.0 +
" meep/1.3_gnu-6.1 +
" meep/1.3_gnu-4.8 +

/opt/app/meep

Meson

Version Module File System A System B,C
0.44 meson/0.44.0 +

/opt/app/meson

When running meson on the login node of system A, the following error occurs.

Meson encountered an error in file meson.build, line 1, column 0:
Executables created by c compiler cc are not runnable.

To avoid the error, please run meson on the computing node (adding tssrun before meson command, for example).

METIS - Serial Graph Partitioning and Fill-reducing Matrix Ordering

Version Module File System A System B,C
5.1.0 cray-tpsl/18.06.1 +
cray-tpsl/17.11.1 +
cray-tpsl/16.12.1 +
5.1.0 metis/5.1.0_intel-17.0-impi-2017.2 +

System A

/opt/cray/pe/tpsl

System B,C

/opt/app/metis

Microsoft R Open

Version Module File SystemA SystemB,C
3.3.2 MRO/3.3.2_gnu-4.8 +

/opt/app/mro

MODYLAS: MOlecular DYnamics software for LArge System

Version Module File System A System B,C
1.1.0b modylas/1.1.0b_intel-18.0 +
1.0.4 modylas/1.0.4_intel-17.0 +

/opt/app/modylas

Observe the licence agreement.

http://www.modylas.org/system/files/MODYLAS_ReferenceManual_v1.0.2_Japanese.pdf

MUMPS : a parallel sparse direct solver

Version Module File System A System B,C
5.2.0 cray-tpsl/19.06.1 +
5.1.1 cray-tpsl/18.06.1 +
cray-tpsl/17.11.1 +
cray-tpsl/16.12.1 +
5.0.2 mumps/5.0.2_intel-17.0-impi-2017.2 +

System A

/opt/cray/pe/tpsl

System B,C

/opt/app/mumps

NAMD

version Module File SystemA SystemB,C
2.14 beta2 namd/2.14b2_intel-18.0-impi-2018.4 +
2.11 namd/2.11_intel-16.0 + +

/opt/app/namd

CISL's NCAR Command Language

version Module File SystemA SystemB,C
6.4.0 ncl/6.4.0 +

/opt/app/ncl

-->

Unidata | NetCDF

  • single execution
version Module File SystemA SystemB,C
4.6.3.1 cray-netcdf/4.6.3.1 +
4.6.1.3 cray-netcdf/4.6.1.3 +
4.4.1.1.6 cray-netcdf/4.4.1.1.6 +
4.4.1.1.3 cray-netcdf/4.4.1.1.3 +
4.4.1.1 cray-netcdf/4.4.1.1 +
4.4.1 cray-netcdf/4.4.1 +
4.4.0 cray-netcdf/4.4.0 +
4.4.0 netcdf/4.4.0_intel-17.0
netcdf/4.4.0_gnu-4.8
+
4.1.3 netcdf/4.1.3_intel-16.0
netcdf/4.1.3_cray-8.5
netcdf/4.1.3_gnu-4.8
+
  • parallel execution
version Module File SystemA SystemB,C
4.6.3.1 cray-netcdf-hdf5parallel/4.6.3.1 +
4.6.1.3 cray-netcdf-hdf5parallel/4.6.1.3 +
4.4.1.1.6 cray-netcdf-hdf5parallel/4.4.1.1.6 +
4.4.1.1.3 cray-netcdf-hdf5parallel/4.4.1.1.3 +
4.4.1.1 cray-netcdf-hdf5parallel/4.4.1.1 +
4.4.1 cray-netcdf-hdf5parallel/4.4.1 +
4.4.0 cray-netcdf-hdf5parallel/4.4.0 +
4.1.3 netcdf-parallel/4.1.3_intel-17.0
netcdf-parallel/4.1.3_cray-8.5
+

System A

/opt/cray/pe/netcdf
/opt/cray/pe/netcdf-hdf5parallel

System B,C

/opt/app/netcdf
/opt/app/netcdf-hdf5parallel

Ninja

Version Module File System A System B,C
1.8.2 ninja/1.8.2 +

/opt/app/ninja

NTChem

Version Module File System A System B,C
2013-12.1 ntchem/2013-12.1_intel-19.3 +
2013-11.1 ntchem/2013-11.1_intel-18.0 +
2013-10.1 ntchem/2013-10.1_intel-17.0 +

/opt/app/ntchem

Observe the licence agreement.

http://molsc.riken.jp/ntchem2013_manual.pdf

NWChem

Version Module File SystemA SystemB,C
6.6 nwchem/6.6_intel-17.0 +
6.5 nwchem/6.5_intel-17.0-impi-2017.1 +

/opt/app/nwchem

Open Computer Vision Library

version Module File SystemA SystemB,C
3.1.0 opencv/3.1.0_gnu-4.8 +
2.4.13 opencv/2.4.13_intel-16.0 +
2.4.13 opencv/2.4.13_gnu-5.3 +

/opt/app/opencv

OpenFOAM Foundation

version Module File SystemA SystemB,C
5.0 openfoam/5.0_intel-17.0-impi-2017.4 +
4.0 openfoam/4.0_intel-16.0-impi-5.1 +
4.0 openfoam/4.0_gnu-6.1 +
2.3 openfoam/2.3.1_gnu-4.8-openmpi-2.0 +

/opt/app/openfoam

When you run the execution script “Allrun” by using the sample program for the tutorial, modify the Allrun script if it includes MPI, as described below.

When running in interactive mode.  Modify the Allrun script as shown below, and run ./Allrun directly.

(Before modifying)
# Source tutorial run functions
. $WM_PROJECT_DIR/bin/tools/RunFunctions

(After modifying)
# Source tutorial run functions
. $WM_PROJECT_DIR/bin/tools/RunFunctions.tssrun

When running in batch mode.  Modify the Allrun script as shown below, and run ./Allrun in the job script.

(Before modifying)
# Source tutorial run functions
. $WM_PROJECT_DIR/bin/tools/RunFunctions

(After modifying)
# Source tutorial run functions
. $WM_PROJECT_DIR/bin/tools/RunFunctions.impi

OpenFOAM The open source CFD toolbox

Version Module File SystemA SystemB,C
v2006 openfoam.com/v2006_gnu-4.8-impi-2018.4 +
v1812 openfoam.com/v1812_intel-17.0 +
v1812 openfoam.com/v1812_intel-17.0-impi-2017.4 +
v1712 openfoam.com/v1712_intel-17.0 +
v1712 openfoam.com/v1712_intel-17.0-impi-2017.4 +

NOTE: Paraview in system A doesn't work. Paraview in v1812 doesn't work.

/opt/app/openfoam.com

OpenMX

version Module File SystemA SystemB,C
3.9.2 openmx/3.9.2_intel-18.0 +
3.8.5 openmx/3.8.5_intel-17.0 +
3.8 openmx/3.8_intel-17.0-impi-2017.4 +

/opt/app/openmx

Paraview - Open Source Scientific Visualization

version Module File SystemA SystemB,C
5.9.0 paraview/5.9.0 +
5.5.2 paraview/5.5.2 +
5.1.2 paraview/5.1.2 +

/opt/app/paraview

METIS - Serial Graph Partitioning and Fill-reducing Matrix Ordering

Version Module File System A System B,C
4.0.2 cray-tpsl/18.06.1 +
cray-tpsl/17.11.1 +
cray-tpsl/16.12.1 +
4.0.3 parmetis/4.0.3_intel-17.0-impi-2017.2 +

System A

/opt/cray/pe/tpsl

System B,C

/opt/app/parmetis

PETSc Home Page

  • real version
version Module File SystemA SystemB,C
3.11.2.0 cray-petsc/3.11.2.0 +
3.9.3.0 cray-petsc/3.9.3.0 +
3.8.4.0 cray-petsc/3.8.4.0 +
3.7.6.2 cray-petsc/3.7.6.2 +
3.7.6.0 cray-petsc/3.7.6.0 +
3.7.4.0 cray-petsc/3.7.4.0 +
3.7.4 petsc/3.7.4_intel-17.0-impi-2017.1
petsc/3.7.4_gnu-4.8
+
3.7.2.1 cray-petsc/3.7.2.1 +
3.7.2.0 cray-petsc/3.7.2.0 +
3.7.2 petsc/3.7.2_intel-16.0
petsc/3.7.2_gnu-4.8
+
3.6.3.0 cray-petsc/3.6.3.0 +
  • 64bit real version
version Module File SystemA SystemB,C
3.11.2.0 cray-petsc-64/3.11.2.0 +
3.9.3.0 cray-petsc-64/3.9.3.0 +
3.8.4.0 cray-petsc-64/3.8.4.0 +
3.7.6.2 cray-petsc-64/3.7.6.2 +
3.7.6.0 cray-petsc-64/3.7.6.0 +
3.7.4.0 cray-petsc-64/3.7.4.0 +
3.7.2.1 cray-petsc-64/3.7.2.1 +
3.7.2.0 cray-petsc-64/3.7.2.0 +
3.6.3.0 cray-petsc-64/3.6.3.0 +
  • complex version
version Module File SystemA SystemB,C
3.11.2.0 cray-petsc-complex/3.11.2.0 +
3.9.3.0 cray-petsc-complex/3.9.3.0 +
3.8.4.0 cray-petsc-complex/3.8.4.0 +
3.7.6.2 cray-petsc-complex/3.7.6.2 +
3.7.6.0 cray-petsc-complex/3.7.6.0 +
3.7.4.0 cray-petsc-complex/3.7.4.0 +
3.7.4 petsc-complex/3.7.4_intel-17.0-impi-2017.1 +
3.7.2.1 cray-petsc-complex/3.7.2.1 +
3.7.2.0 cray-petsc-complex/3.7.2.0 +
3.7.2 petsc-complex/3.7.2_intel-17.0-impi-2017.1 +
3.6.3.0 cray-petsc-complex/3.6.3.0 +
  • 64bit complex version
version Module File SystemA SystemB,C
3.11.2.0 cray-petsc-complex-64/3.11.2.0 +
3.9.3.0 cray-petsc-complex-64/3.9.3.0 +
3.8.4.0 cray-petsc-complex-64/3.8.4.0 +
3.7.6.2 cray-petsc-complex-64/3.7.6.2 +
3.7.6.0 cray-petsc-complex-64/3.7.6.0 +
3.7.4.0 cray-petsc-complex-64/3.7.4.0 +
3.7.2.1 cray-petsc-complex-64/3.7.2.1 +
3.7.2.0 cray-petsc-complex-64/3.7.2.0 +
3.6.3.0 cray-petsc-complex-64/3.6.3.0 +

  • System A

    /opt/cray/pe/petsc
    /opt/cray/pe/petsc-complex
  • System B,C

    /opt/app/petsc
    /opt/app/petsc-complex

RSS21

Please contact us if you want to use this software.

Those who want to use this software must observe the following conditions. (write acknowledgments in your paper, etc.) https://azuma.nims.go.jp/cms1/downloads/software

PLplot Home Page

version Module File SystemA SystemB,C
5.13.0 plplot/5.13.0_intel-17.0 +
5.11.1 plplot/5.11.1_gnu-4.8 +

/opt/app/plplot

PSI4 - OpenSource Quantum Chemistry

バージョン モジュールファイル名 システムA システムB,C
1.1 psi4/1.1 +

/opt/app/psi4

The following four Python language are available for use on the ACCMS supercomputer.

See Anaconda

$ python

See Cray Python

$ python

See Intel Distribution Python

$ python

version SystemA SystemB,C
2.7.13 + -
2.7.5 - +

$ python

/usr/bin/python

Users can install arbitrary packages with pip, the Python package management tool.

# How to install
pip install {Package name} --user

e.g. To install tensorflow
pip install tensorflow --user
# How to uninstall
pip uninstall {Package名} --user

e.g. To uninstall tensorflow
pip uninstall tensorflow --user
pip search {Word or phrase to search for.}

e.g. To find tensorflow
pip search tensorflow
pip list

Quantum ESPRESSO

Version Module File SystemA SystemB,C
6.3 qe/6.3_intel-17.0-impi-2017.4 +
6.3 qe/6.3_intel-17.0 +
6.1 qe/6.1_intel-18.0-impi-2018.0 +
6.1 qe/6.1_intel-17.0 +

/opt/app/qe

The R Project for Statistical Computing

version Module File SystemA SystemB,C
4.1.0 R/4.1.0_intel-18.0 + +
4.0.2 R/4.0.2_gnu-4.8 +
3.6.2 R/3.6.2_intel-18.0 +
3.6.2 R/3.6.2_gnu-4.8 +
3.5.3 R/3.5.3_intel-18.0 +
3.4.1 R/3.4.1_gnu-4.8 +
3.3.1 R/3.3.1_intel-16.0 +
3.3.1 R/3.3.1_gnu-4.8 +

/opt/app/R

RStudio – Open source and enterprise-ready professional software for R

version Module File SystemA SystemB,C
1.0 rstudio/1.0.136 +
0.98 rstudio/0.98.1091 +

* Currently the version 1.0 has a problem that the keyboard mapping becomes scrumbled on Exceed onDemand.

/opt/app/rstudio

[SALMON (Scalable Ab-initio Light-Matter simulator for Optics an D Nanoscience)](http://salmon-tddft.jp/jp/in Dex.html)

Version Module File System A System B,C
2.0.0 salmon/2.0.0_intel-18.0 +
1.2.1 salmon/1.2.1_intel-18.0 +
1.2.0 salmon/1.2.0_intel-17.0 +

/opt/app/salmon

version Module File SystemA SystemB,C
2.5 sals/2.5_cray-8.5 +
" sals/2.5_intel-16.0 + +
" sals/2.5_gnu-6.1 +
" sals/2.5_gnu-4.8 +

/opt/app/sals

$ ifort main.f $SALS_SLIB_D (Static link library in double precision)

$ ifort main.f $SALS_SLIB_S (Static link library in single precision)

$ ifort main.f $SALS_DLIB_D (Dynamic link library in double precision)

$ ifort main.f $SALS_DLIB_S (Dynamic link library in single precision)

When you publish a printed report of a research that uses SALS, you need to include the program name SALS and the name of the author in the report. Copying an installed SALS and giving it to a third party is not allowed.

SCOTCH

Version Module File System A System B,C
6.0.6 cray-tpsl/19.06.1 +
6.0.4 cray-tpsl/18.06.1 +
cray-tpsl/17.11.1 +
cray-tpsl/16.12.1 +
6.0.4 scotch/6.0.4_intel-17.0-impi-2017.2 +

System A

/opt/cray/pe/tpsl

System B,C

/opt/app/scotch

Version Module File System A System B,C
3.6.2 singularity/3.6.2 +

/opt/app/singurality

SLEPc Home Page

version Module File SystemA SystemB,C
3.7.4 slepc/3.7.4_intel-17.0 +
3.7.4 slepc/3.7.4_intel-17.0-impi-2017.2 +
3.7.4-complex slepc-complex/3.7.4_intel-17.0 +
3.7.4-complex slepc-complex/3.7.4_intel-17.0-impi-2017.2 +

/opt/app/slepc
/opt/app/slepc-complex

SMASH

Version Module File System A System B,C
2.2.0 smash/2.2.0_intel-17.0 +

/opt/app/smash

SmokeView

Version Module File SystemA SystemB,C
6.7.14 smokeview/6.7.14_intel-18.0 +

/opt/app/smokeview

SuperLU

version Module File SystemA SystemB,C
6.1 cray-tpsl/19.06.1 +
5.2 cray-tpsl/18.06.1 +
cray-tpsl/17.11.1 +
cray-tpsl/16.12.1 +
5.2.1 superlu/5.2.1 +

System A

/opt/cray/pe/tpsl

System B,C

/opt/app/superlu

The Trilinos Project

version Module File SystemA SystemB,C
12.14.1.0 cray-trilinos/12.14.1.0 +
12.14.0 trilinos/12.14.0_intel-18.0-impi-2018.3 +
12.12.1.1 cray-trilinos/12.12.1.1 +
12.10.1.2 cray-trilinos/12.10.1.2 +
12.10.1.1 cray-trilinos/12.10.1.1 +
12.10.1 trilinos/12.10.1_intel-17.0-impi-2017.2 +
12.8.1.0 cray-trilinos/12.8.1.0 +
12.6.3.3 cray-trilinos/12.6.3.3 +
12.6.3.1 cray-trilinos/12.6.3.1 +
12.2.1.0 cray-trilinos/12.2.1.0 +

System A

/opt/cray/pe/trilinos

System B,C

/opt/app/trilinos

WRF Model UsersSite

version Module File SystemA SystemB,C
3.8.1 wrf/3.8.1_cray-8.5 +
" wrf/3.8.1_intel-16.0 + +

We provide the compiled module file as a sample, because the WRF includes various simulation models. Please copy the sample configuration file depending on the simulation model you use, compile in your own local environment.

The example below shows how to compile in the system A.

  1. Set up the environment.
    $ module switch PrgEnv-cray PrgEnv-intel
    $ module load cray-netcdf
    $ export NETCDF=/opt/cray/pe/netcdf/4.4.0/intel/150
  2. Download the source at the WRF website, then overwrite the configure_new.defaults file in the WRFV3/arch/ directory with the file in the following directory.
    /opt/app/wrf/3.8.1/intel-16.0/arch/configure_new.defaults
  3. Execute the ./configure in the WRFV3 directory. Items for each compiler will be displayed. Select one of the following: serial, smpar, dmpar, or dm+sm.
  4. Compile by the model you need, according to the menu of the ./compile command.

/opt/app/wrf

Vim

version Module File SystemA SystemB,C
8.2 vim/8.2 + +

/opt/app/vim

VisIt

version Module File SystemA SystemB,C
2.11.0 visit/2.11.0 +

/opt/app/visit

VTK - The Visualization Toolkit

version Module File SystemA SystemB,C
8.2.0 vtk/8.2.0_gnu-6.1 +
8.2.0 vtk/8.2.0_gnu-8.2 +
7.1.1 vtk/7.1.1_intel-18.0 +

/opt/app/vtk

Visual output functions using OpenGL are not available in system A.


Copyright © Academic Center for Computing and Media Studies, Kyoto University, All Rights Reserved.